Launching Gazebo Gui Through noVnc Custom App

Hello Yonohub Community,
I’ve tried to use my yonohub as my local machine, which lets me create my own workspace and run the ROS simulation tools such as Gazebo, Rviz, Rqt, and Stage.

In this discussion, I’ll explain my trial to run the Gazebo simulator thru the novnc custom app. Firstly, I’ve created my environment thru yonobuilder and be sure that your environment doesn’t include the gazebo plugins, it has the noVnc as a dependency, and it has an Enable Launch Settings option. Then I released this environment.

Secondly, I’ve created my custom app as it’s explained in the yono docs using that environment. Then I released my custom app (noVnc) which enabled me to ssh to my remote instance.

Finally, I run my noVnc and opened the terminal, where I got half of my seek. I tried to launch the gazebo empty world using this command roslaunch gazebo_ros empty_world.launch, but I got several errors, most of them had been solved with those command:

sudo apt upgrade libignition-math2
sudo apt-get install -y at-spi2-core

Also, I found those links very related to other errors:

http://answers.gazebosim.org/question/22263/error-in-rest-request-for-accessing-apiignitionorg/

http://answers.gazebosim.org/question/2456/simulator_gazebogazeboscriptsgui-core-dumped/

The last error I’ve stuck in it, to display my gazebo gui via my noVnc window. I think it’s a bug to be solved thru the Yonohub developers, so I created an issue for it hopefully to be solved as soon as possible.

I hope this post will be useful
Thanks